Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[1.14] Game freezes on "Loading..." dialogue - cannot play.
Machine: Windows 7 Professional SP1 64-bit, Intel Core i7 930, NVIDIA GeForce GTX 680

The game will freeze for me on the "Loading..." dialogue every time I attempt to start a game. This happens whether I'm starting a tutorial or new game. Upon clicking the button, the black loading screen will appear and the circular spinner will spin briefly. After about 2 seconds, the spinner will stop and the game will sit on the loading screen indefinitely.

I attempted to uninstall the game and reinstall, and even attempted to do this to a different drive (I was originally installed to my Steam Library on my SSD and tried reinstalling to my Steam folder on the C: drive), but that did not resolve the issue.

I found the following issue report:

I tried deleting the save file as described ( even though I hadn't started a game yet and had already tried several reinstalls ), but that did not fix the issue, either.

At the moment, I'm simply out the $15 I payed to play the game, as I cannot play at all!
hi Glordag, sorry you're having a problem, and I'd like to help you fix it! A few thoughts:

1. if you could send me your save game files as described in this guide (to, I can take a look and see if I get the same issue on my machine. Guide:

2. The normal behavior for the game is to for the loading spinner to stop moving for a just a short while (on the initial "Generating World. Please Wait..." screen, it will stall for a bit while it does some heavy loading). As a test, I'd suggest letting the game sit on the initial loading screen for 5 minutes, just to see if the game ever does load. If it does load, but is just taking an extra long time on your machine, that would be good to know. If it doesn't, we obviously have either a crash or hardware incompatibility that we didn't know about and need to investigate further.

3. Did you adjust the window size from the settings menu? If so, try running the game at a smaller or different resolution and see if you get any different behavior.

4. When deleted the save file, did you delet all of the files that end with .xml? I'd try that if you didn't.

Again sorry for your trouble, and thanks in advance for any more info you can provide.
Founder, Lead Designer on Hero Generations
Same issue here:
intel i7.
win7 pro
AMD Radeon R9 200 Series

reinstalled, tried c.d.e drives, etc. yada yada. will not load tutorial or a new game. credits play fine.

Sent the two xml files that exist. There IS no savegame, get it?
Thank you for the response. As requested, I submitted a bug report to the support email address with my screenshots and XML files. I did try deleting all of the XML files, rebooting my computer, and waiting for about 10 minutes, all to no avail. I hope a solution can be found, soon.

Edit: I forgot to mention that I did adjust the display size first thing when I started the game, originally. I don't know if that matters or not.

I have also tried manually deleting the leftover folders in the Steam directories both on the SSD I originally installed to and my C: drive, which has also not helped.
Im having the same problem just got the game and it isnt working stuck on loading screen. I tried changing resolutions but no luck reinstalled a bunch of times no luck

please help i just want to play the game Sad
Could i get an older version of the game so i can play it untill this is fixed?

Forum Jump:

Users browsing this thread: 1 Guest(s)