Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Save Bug
#1
I had gotten to a 6th generation and exited but on loading it was back at the first generation at the end of his life. Is this a known bug with saving or is there some other thing going wrong? On starting a new game it seemed to save correctly but I haven't gotten back to 6th gen yet.
Reply
#2
I haven't seen this bug before. If it happens again, please follow this handy guide for sending us your save files so that we can debug the issue on our end! http://heartshapedgames.com/forums/showt...hp?tid=332

Also, were you a beta player at all, or are you playing new on Steam? Thank you.
Founder, Lead Designer on Hero Generations
http://www.twitter.com/brodiegames
Reply
#3
I am playing new on Steam. I'll send the save file if it happens again though.
Reply
#4
I am also playing on Steam and had the same thing happen around generation 10. Sad Guess I will never close the game again. I will send save files, but I have restarted the game a couple times so I suspect the save files are not in the same state as when the load bug happened.
Reply
#5
I am also getting the bug where when I exit a character has plenty of life left and when I restart and load they have none effectively killing the generations.

I'm playing on Steam. FWIW my system specs are:

OS: Windows 8.1 Pro 64-bit
CPU: Intel i7-4771 3.50GHz
Video: GeForce GTX 780
RAM: 8GB

Full DX Diag: http://pastebin.com/vEjCZ4Yq
Reply
#6
I am also having this problem. The first time I played, I started with the Tutorial and got to at least the 10th generation and over 14,000 fame. I couldn't see any way save the game or even access a menu so I simply closed the game by clicking the X in the upper right corner. The next time I opened the game, I selected the Load Game option and it loaded a game that was at 2nd generation with only 530 fame.

I started my second game as by choosing the New Game option. I played through at least 10 generations again, getting to over 10,000 fame, and once again exited the game by clicking the X in the upper right corner. Upon starting the game back up and choosing the Load Game option, I was once again presented with a character that was only 2nd generation and 530 fame. As best as I can tell, this is the exact same character I saw the first time.

I attempted to attach my save file (saveSlot0.xml), but got an error message telling me: "The type of file that you attached is not allowed. Please remove the attachment or choose a different type."
Reply
#7
Hi! I've just released a fix build that should resolve this. Take a look here, make sure to grab v1.15 from steam, and let me know if you still have problems: http://heartshapedgames.com/forums/showt...hp?tid=345
Founder, Lead Designer on Hero Generations
http://www.twitter.com/brodiegames
Reply
#8
(04-13-2015, 06:01 PM)scott Wrote: Hi! I've just released a fix build that should resolve this. Take a look here, make sure to grab v1.15 from steam, and let me know if you still have problems: http://heartshapedgames.com/forums/showt...hp?tid=345

I just tried it out and it appears to be saving just fine. Thank you very much for fixing this Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)